You are not logged in.

Read the FAQ and Knowledge Base before posting.
We won't make a 3DS/2DS emulator.



#1 2009-01-06 20:50:42

Bleuarg
Member
Registered: 2009-01-06
Posts: 6

0.9, Mac-intel only?

It seems the mac binary is intel only unlike 0.8. Does it mean there will be no ppc version?

Last edited by Bleuarg (2009-01-06 20:51:00)

Offline

#2 2009-01-07 04:38:41

someone
Member
Registered: 2009-01-07
Posts: 48

Re: 0.9, Mac-intel only?

The sourceforge download page states this is supposed to be a ppc/x86 binary (ie. universal binary). So I guess the devs made a mistake?

Offline

#3 2009-01-07 10:15:54

shash
Administrator
Registered: 2007-03-17
Posts: 897

Re: 0.9, Mac-intel only?

someone: That information might have been copied from the last release, yes.

Offline

#4 2009-01-27 18:34:56

Bleuarg
Member
Registered: 2009-01-06
Posts: 6

Re: 0.9, Mac-intel only?

Is it possible it will work for my ppc if i compile it myself? (I'm not very familiar with development)

Offline

#5 2009-01-27 19:57:36

shash
Administrator
Registered: 2007-03-17
Posts: 897

Re: 0.9, Mac-intel only?

Bleuarg: Don't really know, you should wait until the Mac porter comes by and says something.

Offline

#6 2009-01-28 03:24:44

Arakun
Member
From: Sweden
Registered: 2009-01-20
Posts: 14

Re: 0.9, Mac-intel only?

Bleuarg wrote:

Is it possible it will work for my ppc if i compile it myself? (I'm not very familiar with development)

It compiles just fine for PPC if that's what you're asking. It's simply missing from the list of architectures in the project/target settings. I tried running a universal build through Rosetta and it crashed. Maybe you'll have better luck on a real PPC.

Do you have any experience with XCode? If so it should be quite trivial for you to add PPC to that list and hit the "build" button.

Offline

#7 2009-01-31 04:05:53

jeff
Member
Registered: 2008-04-06
Posts: 47

Re: 0.9, Mac-intel only?

It should, at least, compile for PPC. As to whether it actually works, I'm not sure. it may have regressed. It looks like I spaced out when building it for release and forgot to make it a universal binary. If I have a some time I'll try to check up on the PPC status.

Offline

#8 2009-01-31 16:13:42

Bleuarg
Member
Registered: 2009-01-06
Posts: 6

Re: 0.9, Mac-intel only?

Arakun wrote:

Do you have any experience with XCode? If so it should be quite trivial for you to add PPC to that list and hit the "build" button.

Not really. I've tried to compile it with terminal, "configure" seems to work but there are lot of error when i "make" about OGLrender if i remember well.

Offline

#9 2009-02-11 20:01:57

Bleuarg
Member
Registered: 2009-01-06
Posts: 6

Re: 0.9, Mac-intel only?

jeff wrote:

It should, at least, compile for PPC. As to whether it actually works, I'm not sure. it may have regressed. It looks like I spaced out when building it for release and forgot to make it a universal binary. If I have a some time I'll try to check up on the PPC status.

Any news on the PPC status?

Anyway thanks for the answer slash, arakun, jeff...

Offline

#10 2009-02-11 21:23:51

shash
Administrator
Registered: 2007-03-17
Posts: 897

Re: 0.9, Mac-intel only?

No news. And you wrote my nick wrong tongue

Offline

Board footer

Powered by FluxBB