You are not logged in.

Read the FAQ and Knowledge Base before posting.
We won't make a 3DS/2DS emulator.



#1 2022-09-02 03:25:36

sickbutt
Member
Registered: 2022-09-02
Posts: 6

Loading save state crashes emulator

Game : Lufia - Rise of the Sinistrals

save stating works fine
loading works fine the first or second time when starting the emulator and game, but crashes after

Ive noticed if I set sound settings to synchronous instead of the default "dual SP" is when the crashes start. But dual SP makes the sound very laggy and choppy.

Also of note... I played and beat Lunar Knights from start to finish with the same settings as above and used save states extensively with no issue. Not sure if Lufia is the issue or not?

Offline

#2 2022-09-02 17:37:10

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,914

Re: Loading save state crashes emulator

which EXACT version of the emulator, downloaded from EXACTLY what URL?

Offline

#3 2022-09-02 23:29:55

sickbutt
Member
Registered: 2022-09-02
Posts: 6

Re: Loading save state crashes emulator

I use the one from here

DeMuMe 0.9.13x64 SSE2

Offline

#4 2022-09-03 00:26:49

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,914

Re: Loading save state crashes emulator

not enough detail. I asked for exact version and exact URL. you gave no URL, and a vague name which may apply to 1000s of exact versions.

Offline

#5 2022-09-03 17:59:26

sickbutt
Member
Registered: 2022-09-02
Posts: 6

Re: Loading save state crashes emulator

https://github.com/TASEmulators/desmume … ase_0_9_13

https://github.com/TASEmulators/desmume … -win64.zip

the link from the official DeSmume website, version 0.9.13-win64

Last edited by sickbutt (2022-09-03 18:00:08)

Offline

#6 2022-09-04 04:12:59

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,914

Re: Loading save state crashes emulator

synchronous is the default. You're playing CURSE of the sinistrals, not RISE of the sinistrals. So you're confused on a number of points here.
The notion that changing the SPU mode can cause crashes when loading IN-GAME SAVES is......... nearly preposterous. It could cause problems with savestates, but in-game saves is just unbelievable. Are you perhaps confused about which of those two you're using?
What's more, it's INSANELY unbelievable that you could load an in-game save several times, closing the emulator inbetween, and then find that suddenly you no longer can (and never ever could again? Did this pattern repeat somehow?)

Also I'm unable to reproduce the problem, anyway (and it would be the first time I'd ever seen the emulator crash while loading an in-game save that hadn't been hacked). Perhaps you should try explaining the situation muuuuuuuuch more clearly

Offline

#7 2022-09-04 22:52:10

sickbutt
Member
Registered: 2022-09-02
Posts: 6

Re: Loading save state crashes emulator

Apologies for the confusion, but this is only with SAVE STATEs. Not normal in game saving. And yes I meant Curse of the Sinistrals, the old classic name seems to have stuck and I confuse the two... granted we ARE on the DS board so it should be fairly obvious I was referring to the DS version/remake.

AGAIN... this issue is with SAVE STATES, not regular saving (which I thought I emphasized with the closing note about Lunar Knights @_@).

Offline

#8 2022-09-05 18:16:48

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,914

Re: Loading save state crashes emulator

Can you please explain the repro steps more clearly? "Loading works fine the first or second time when starting the emulator and game, but crashes after" isn't precise enough. Loading what? When?

Offline

#9 2022-09-06 02:39:54

sickbutt
Member
Registered: 2022-09-02
Posts: 6

Re: Loading save state crashes emulator

Sure. When I start up the emulator, start the game and load my save state it works, I make a mistake and reload the save state, good. I try to reload the save state a third time it crashes. Its inconsistent, sometimes it crashes upon loading the save state the second time, and sometimes it happens on the third reloading of the save state.

Offline

#10 2022-09-06 03:01:01

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,914

Re: Loading save state crashes emulator

OK, that sounds good. Can you post the savestate you're using?

Offline

#11 2022-09-06 16:48:34

sickbutt
Member
Registered: 2022-09-02
Posts: 6

Re: Loading save state crashes emulator

Here you go.

https://www.mediafire.com/file/0yhh6t47 … s.ds0/file

Also is there a way to limit or stop the save state backups?

Offline

#12 2022-09-06 17:15:38

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,914

Re: Loading save state crashes emulator

I think in recent buildbot versions it's limited to 99 or something like that

Offline

#13 2022-09-11 03:36:22

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,914

Re: Loading save state crashes emulator

I can't get this state to crash. Is there some secret method? What exactly are you doing here? I may need to ask for the most excruciatingly precise series of steps imaginable.

Offline

Board footer

Powered by FluxBB