You are not logged in.

Read the FAQ and Knowledge Base before posting.
We won't make a 3DS/2DS emulator.

#1 Re: Support » so slow, is it normal? » 2007-08-01 13:30:48

Don't expect a beta release to be working with top speed, when some of the basic functions aren't even emulated yet. tongue

First compatibility, then speed.

#2 Re: Support » Ace Attorney, stuck on first judge question, what's the defendant name » 2007-08-01 13:28:19

and i get a weird green color all around of a button (on clickable option button in the game)

That's just the 3d objects not having texture masking done yet or something. The fix for that won't be released for a while.

#3 Re: General » Emulator Screen Size Issue » 2007-06-14 18:54:51

I believe that 3D rendering bug you mean, is the transparency issue Serio...so it's not really a bug.

I mean 3d rendering thing. Zoom in on the first shot to notice those black lines between red and white parts, which shouldn't be there and isn't on the second one. As far as i remember the bug first appeared when ideas implemented 3d support over a year ago and been around ever since then. When you try to move around with the camera, the screen has this 'floating' effect too, since it removes one vertical line and two horizontal ones.

It's kind of an issue when you try to get pixel perfect sprites like I do.

I use different window sizes on my build, as I don't support rotation neither scaling, basically the old 0.3.3 window code, that's why mine might look different. It's not fixed, it's simply untouched

So wait, it's more like the bug isn't present there due to the lack of those features? tongue

#4 Re: General » Emulator Screen Size Issue » 2007-06-14 15:53:13

This:
desm1.png desm2.png
This is how the current cvs looks like:            And this is how Shash's blog screenshot looks like:
I put a white outline around the screen for easier noticing. Notice the black lines on the top and right side of the screen on the upper screenshot.

Edit: Ah, wait, i see what you mean now. The desmume on his screenshot looks really squashed. I guess I misunderstood him. tongue
I thought he meant the 3d rendering bug, since desmume is right now the only ds emulator with that bug still present.

#5 Re: Support II (decommissioned) » Firmware settings now work!! » 2007-06-14 15:38:02

You can change the languages in config/firmware I think.

#6 Re: General » Emulator Screen Size Issue » 2007-06-14 15:33:50

No, I mean the rendering bug, not vista bug. I have xp too, the screen in the most recent cvs version is still 255x190, with the remaining 1x2 pixels being displayed as black lines on top and right side of the screen in 3d games.

From what I understood by reading the first post that's what the author meant too, since the vista bug is probably universal, and right now only desmume incorrectly renders the screen size.

#7 Re: General » Emulator Screen Size Issue » 2007-06-14 14:57:55

Oh? Weird, I could swear the castlevania dos screenshot on your blog was rendered in 256x192, not 255x190 like the current cvs build does.

#8 Re: General » Emulator Screen Size Issue » 2007-06-13 21:05:25

That thing is already known. Shash fixed it, but he still doesn't want to commit it to the cvs, probably still bugtesting it.

There are no more wireframe lines in desmume btw. Only in ideas.

#9 Re: General » problem trying to compile desmume » 2007-05-26 23:07:21

Just tried, everything worked fine and compiled without problems. So far the only difference i see is that the dropdown menus for the debug tools are fixed and actually visible now.

Also just for fun I fixed three trivial text things that were leftovers from the old french version in the files. tongue

#10 Re: General » problem trying to compile desmume » 2007-05-25 12:39:02

Yes. Although the cvs version has supposedly more bugfixes I heard.

I tried to compile it too, but it appears Visual C++ 6.0 isn't going to work, and to get Visual Studio demo to even install I need to install service pack 2 which I detest. tongue

#11 General » application error - 0.7.0 » 2007-05-12 06:48:59

Serio
Replies: 10

I have noticed there's a new release, so i went to test it. However, as soon as I start it i'm getting a "Application wasn't correctly initialised (0xc0150002). Click ok to end the application". Does it require some additional library not mentioned anywhere, or am i just unlucky?

For the record, I have Windows XP Professional SP1 Polish edition, AMD sempron 64 bit 3000+, 1024 mb ram and a geforce fx 6100.

Edit: However, deleting zlib1.dll which was included in the package somehow fixed that. Weird.

#12 Re: Support II (decommissioned) » Advance Wars DS » 2007-05-04 23:29:01

If the texture bug was fixed (and it seems it was, seeing the latest screenshots on the blog), then most likely it's fixed.

#13 Re: General » problems with mic on DS » 2007-04-29 21:34:16

it is the onli game i found on the net tat can be played on this emu

You're a pirate, it's against general emulation rules to mention obtaining illegal copies of the game on emulation related forums.

#14 Re: General » It has been 3 months since the last emulator release. » 2007-04-29 02:32:31

but how with the pokefans catch them all?!?!

Well, they can... buy the game and a ds! yikes *gasp*

tongue tongue tongue

#15 Re: Support » Noob at using Desmune » 2007-04-28 23:48:01

Turn off frame skip, get a better cpu, wait for new version of emulator. tongue

#16 Re: General » German desmume » 2007-04-28 23:43:57

It would be great if the future versions could include an ini based text files, so that people could submit their translations without having to modify the exe file and make it obsolete each time a new version/wip comes out.

I would be interested in making a Polish translation then.

#17 Re: General » It has been 3 months since the last emulator release. » 2007-04-28 22:01:01

It will be out when it's out and pokeymans aren't anywhere near the top priority to get working. tongue

#19 Re: General » non-english forums » 2007-04-17 22:56:25

You don´t can ??constrain?? someone to learn english because he want to use desmume.

Nope. It was more about this forum. English is preferred if you want to post on the english speaking forums like this one. This place seems more development oriented, so for a casual gamer it's not really that beneficial anyway.

#20 Re: General » non-english forums » 2007-04-13 15:16:38

I agree with no need for more forums. It's fine if the forum is big and has hundreds/thousands of active members, but this place is still kinda far from that. tongue

#21 Re: Support II (decommissioned) » Kirby Squeak Squad is dead! » 2007-04-10 11:57:17

There aren't all possible savetypes in desmume though, so in some cases it won't work anyway. Izuna for example fails on all of the options. I heard it requires a flash 256 kbit or something which isn't present there.

#22 Re: General » Direct3D version released » 2007-04-05 18:41:12

Doesn't seem like the 3d was fixed all that much, it looks just like the latest unofficial build with the missing textures and all except it's all black. tongue

The new debugging tools seem interesting, though they barely work. It would be interesting to have a debug tool that allows to disable each music channel unless the tool's just for viewing how they act. Too bad they killed the old ones though.

#23 Re: General » Direct3D version released » 2007-04-05 16:18:30

It's obviously very broken and buggy. It calls homebrews and demos pirates too. tongue

Silly japanese people. "Englished desmume info."

#24 Re: Support II (decommissioned) » Advance Wars DS » 2007-04-05 16:17:10

It's possible that layer is supposed to be clouds and the game makes it transluscent. The emulator doesn't have that function implemented yet though, so you gotta wait till one of the future WIP versions with that function implemented is released I guess. tongue

#25 Re: Support II (decommissioned) » Castlevania Dawn of Sorrow Crash » 2007-03-30 15:06:25

Confirmed using the latest WIP. The game crashes as soon as you enter the menu, before anything from the menu itself appears.

Board footer

Powered by FluxBB