You are not logged in.

Read the FAQ and Knowledge Base before posting.
We won't make a 3DS/2DS emulator.



#1 2022-08-18 16:21:23

seethelight
Member
Registered: 2022-08-18
Posts: 3

Can't save using in-game saving, using latest version + Can't fix it

I downloaded the most recent version of the emulator a few days ago to emulate some Ace Attorney games. Today when I loaded the ROM for one of them (this being my first time doing so), I got this message: ''Could not get read/write access to the battery save file! The file will not be saved in this current session.
Choose Config > Path Settings and ensure that the SaveRam directory exists and is available for read/write access.''.

I was told in-game saving would work so I didn't give it too much thought (my bad, I know). I checked the settings anyway and set it to an existing directory, then when it actually saved in-game, it hadn't ACTUALLY saved. So I googled it up and I came across a thread from two months ago stating that it could be because my Windows username has a non-English character. Which is true, my name has a non-English character because my name isn't English. I can't change the username and, despite coming across a GitHub link that was supposed to fix it, I can't seem to be able to download said ''patch'' or whatever it might be called. This is the link in question:
https://github.com/TASEmulators/desmume … bce32e63dc

Where is the download link supposed to be? Is there a different issue with my directories? (I made a new folder in my desktop since I saw that it could fix it as well, but it didn't do anything)

EDIT: This is what I mean. The artifact is there but there's no option to download it. Do I need to create a GitHub account to do that?

https://ibb.co/7Gdn0pW

Last edited by seethelight (2022-08-18 16:29:04)

Offline

#2 2022-08-19 09:39:01

seethelight
Member
Registered: 2022-08-18
Posts: 3

Re: Can't save using in-game saving, using latest version + Can't fix it

UPDATE: I changed my username (turns out there was a way to do it), even created a new user directory with strictly English characters, directed everything in the emulator to get saved there, and it STILL gives me the error message. What can I do to solve this??

Offline

#3 2022-08-19 11:36:47

someone
Member
Registered: 2009-01-07
Posts: 78

Re: Can't save using in-game saving, using latest version + Can't fix it

download artifact = click "desmume-win-x64"

Offline

#4 2022-08-19 12:48:19

seethelight
Member
Registered: 2022-08-18
Posts: 3

Re: Can't save using in-game saving, using latest version + Can't fix it

That's what I couldn't do.

BUT I did find another way to fix it that I haven't seen anyone mention around the web, so I'll write it down in case someone needs it:

1) I created a new user with no English characters.
2) I put both the emulator and the ROM files there.
3) I edited the properties for the new user's folder so that anyone can write on them (under the ''security'' section. The option for anyone to write on them was turned off by default). This is important because I believe it's what gives the emulator access to writing the save files.
4) Upon running the emulator, I changed all save/battery/etc directories to those existing within the new user's folders. The ones whose properties I just edited.
5) Done. It saves perfectly now.

Now that my problem is solved feel free to close this thread. Apologies for the inconvenience!

Offline

#5 2022-08-19 15:47:24

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,949

Re: Can't save using in-game saving, using latest version + Can't fix it

desmume doesn't know anything about user directories. easiest way to solve this is to use a directory that's not a user directory and doesn't have strange letters or spaces. c:\desmume works nicely.

Offline

Board footer

Powered by FluxBB