You are not logged in.

Read the FAQ and Knowledge Base before posting.
We won't make a 3DS/2DS emulator.

#1 2019-04-16 14:46:28

Registered: 2019-04-16
Posts: 9

lua51.dll is not found.

Hello, I'm having a problem with lua51 on stable releases and source code. I downloaded and compiled a source code binary, as well as the lua binary within it at the same time, but when I set my path to direct to lua's containing folder, it still show the error: lua51.dll was not found.

Do I need some kind of Microsoft Redistrubable or a package to make this work? I have c++ 2010 64 bit and 2010 x86. I tried this on multiple emulators, including 64 and 32 bit emulators.

I have a feeling that I have forgotten a key step, but there's hardly any documentation out there to explain how to set this up!

EDIT: I forgot to mention a few things

I am running windows 10 pro x64 bit, if that could make a difference.

I've tried using Source Forge's 5.1.5 dll of lua51.dll, still no dice

I have set the path to the containing folder of lua51.dll.

I have put lua51 in the directory of the emulator as well.

I have tried many versions of 9.11, 9.12, and 9.7, no dice.

Could a program redistributable be conflicting with the dll?

Do I need to reset my PC again to make it work?

Last edited by Bnthomason (2019-04-16 14:55:04)


#2 2019-04-16 16:21:44

Radical Ninja
Registered: 2009-01-05
Posts: 5,704

Re: lua51.dll is not found.


Board footer

Powered by FluxBB