You are not logged in.

Read the FAQ and Knowledge Base before posting.
WiFi not emulated and not supported!!
We won't make a 3DS/2DS emulator.



#1 2017-07-29 06:24:33

mgitkun
Member
Registered: 2017-06-06
Posts: 20

Record AVI - minor issues

Everything was tested on the most recent build at the time (d08dffd1) downloaded from AppVeyor and run at these settings.

1.
Whenever DeSmuME creates a new file segment during a recording session there's a misleading message on the HUD that reads "AVI recording ended."
This is a minor issue because the message should probably tell you there was a split or better yet not say anything at all because getting that message in the middle of a recording can lead to misunderstandings if you don't know to disregard it, recording does not actually stop until you end the session the issue is simply that the message incorrectly appears during splits.
Unless I'm mistaken this message (and its counterpart) should only appear at the start and end of a recording.


2.
If you have multiple recording sessions without restarting the program DeSmuME will fail to reset the file naming scheme; that is to say that if your previous recording session ended with _part40 your next recording session will start off at whatever name you give the file but then the second file in the series will be _part41 rather than _part2, the third being _part42 rather than _part3, the fourth being _part43 rather than _part4, and so on.



3.
When/if you run out of disk space before manually ending the recording session the final segment of the session seems to be perpetually accessed by DeSmuME.
The recording IS ended the moment that you run out of disk space, there's no overwriting shenanigans like there were before; virtually no reads or writes are being done on the disk at this point.
I guess it does a 'soft stop', at which point you can't read the final file segment nor can you modify it because it's still being accessed by DeSmuME.
You can't end the recording to stop DeSmuME from accessing the file because the drop-down menu under file -> Stop AVI has vanished and been replaced with file -> Record AVI.
So in order to do anything with the final segment you have to close DeSmuME or start a new recording session which will create a new file and stop DeSmuME from accessing the other file.

After doing either of the above the final segment reads fine and has no corrupt frames, it does seem to be missing the last two or three seconds of gameplay before recording actually ended though that's probably to be expected.

Last edited by mgitkun (2017-07-29 07:04:20)

Offline

#2 2017-07-29 18:47:59

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 4,591

Re: Record AVI - minor issues

all bugs fixed

Offline

#3 2017-07-29 19:56:21

mgitkun
Member
Registered: 2017-06-06
Posts: 20

Re: Record AVI - minor issues

zeromus wrote:

all bugs fixed

Can confirm that all of the above bugs are fixed.

There's now a much larger issue though; after filling the second segment (_part2) to the ~1.75GB limit the data in that segment is deleted and the next chunk of data is written to that same segment (_part2) over and over again, this continues forever until you stop recording.

Offline

#4 2017-07-29 21:45:24

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 4,591

Re: Record AVI - minor issues

all bugs fixed more for real

Offline

#5 2017-07-30 02:35:46

mgitkun
Member
Registered: 2017-06-06
Posts: 20

Re: Record AVI - minor issues

zeromus wrote:

all bugs fixed more for real

Just tried recording on the latest build (5deec254) and there don't seem to be any issues, thanks for the quick fixes.  smile

Offline

Board footer

Powered by FluxBB