You are not logged in.

Read the FAQ and Knowledge Base before posting.
WiFi not emulated and not supported!!
We won't make a 3DS/2DS emulator.



#1 2017-05-14 16:20:38

Alicia_Straymaus
Member
Registered: 2017-05-14
Posts: 3

Sound Crackle (I've Tried Everything!)

Hello there, I do not mean to beat a dead horse here, as I've noticed this to be quite a prevalent question all over the internets. However, I just cannot seem to make any of the solutions I've come across work. I have a strong sound crackle issue, specifically in situations of voices, cut scenes, and certain ambient sound effects. Music and most normal sound effects tend to play fine, thankfully. However, in some games, specifically the castlevania games, this crackling becomes grating to the point of unplayability. I don't understand why this is. My frames are fairly high, hovering around 60, and the games run beautiful otherwise. I've attempted the following, but nothing has worked. I have:

Attempted to switch to synchronization mode, using all three methods.

Attempted to use both interpolation modes.

Attempted to us both sound cores.

Attempted to mess with the buffering.

Attempted to change all manner of emulation and 3D settings, just in case.

Attempted to turn on Advance SPU Logic.

Attempted every possible combination of each of the previous attempts as I could think of.

   Nothing has worked however, as a matter of fact, in most situations, changing these things just made the situation worse and it is beginning to grow a little frustrating. I was wondering if this was just an issue with the emulator or is there a fix out there? I am using 9.11 currently, but I do remember using this emulator a year or two back and not having this issue at all. Any help would be greatly appreciated... and thank you in advance.

Offline

#2 2017-05-14 17:45:26

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 4,645

Re: Sound Crackle (I've Tried Everything!)

voices, cutscenes, and ambient sound effects are fixed by picking "synchronous", disabling vsync, and having an adequate computer. If it worked a year or two back then what's probably changed is your video drivers, and vsync. Try changing config > display method to interfere with your gpu wrecking your gaming

Online

#3 2017-05-14 21:25:37

Alicia_Straymaus
Member
Registered: 2017-05-14
Posts: 3

Re: Sound Crackle (I've Tried Everything!)

Changing Vsynce doesn't seem to help, and the synchronous modes only prove to make the crackle even worse. It should not be my system at all, it's a fairly decent rig. Plus, I played a laptop with a worse set up then my pc when I used the emulator a few years back. I'll check my drivers and what not though, see if that helps.

Last edited by Alicia_Straymaus (2017-05-14 21:25:53)

Offline

#4 2017-05-15 03:46:12

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 4,645

Re: Sound Crackle (I've Tried Everything!)

better hardware doesnt mean less bug-free drivers and gpus. theyre screwing stuff up all the time. could also be some desktop enhancements or bloatware or power control on your system that makes the framerate erratic

Online

#5 2017-05-17 03:46:09

Alicia_Straymaus
Member
Registered: 2017-05-14
Posts: 3

Re: Sound Crackle (I've Tried Everything!)

That's super fair, but when playing with the HUD on my frames stick pretty solidly at 60, so erratic frame rates aren't the issue here, as I've already said. Not unless they're changing so quickly that the HUD can't keep up with it.

Offline

#6 2017-05-22 02:38:39

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 4,645

Re: Sound Crackle (I've Tried Everything!)

hiccups less than 1 frame might not show up on the hud but will be enough for the audio to spaz.

Online

Board footer

Powered by FluxBB