You are not logged in.

Read the FAQ and Knowledge Base before posting.
We won't make a 3DS/2DS emulator.



#1 2013-12-10 17:31:03

Pingouin7
Member
Registered: 2013-12-10
Posts: 8

Save files being corrupted on read? (v0.9.10)

I am able to load save files properly after saving in-game.
However, when I try to load a save file after editing it with PokéGen, it acts as if there is no save file and the save gets deleted.

The thing is, if I rename that same save file to a .sav extension and load it from the File --> Import Backup Memory, that very same save file works fine.

It worked fine in v0.9.9; v0.9.10 might have broken something, or it might be an issue on PokéGen's end.

In any case, I've posted the same question over on ProjectPokémon, since I'm not sure if DeSmuME or PokéGen is the problem.
Hopefully, both parties can investigate and we can see which of the two is causing problems. I'm leaning towards DeSmuME v0.9.10 being the problem, but I'm not sure.
Could the JIT recompiler be causing issues with save files?

Last edited by Pingouin7 (2013-12-10 17:31:34)

Offline

#2 2013-12-10 18:10:14

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,710

Re: Save files being corrupted on read? (v0.9.10)

lots of save code got changed in 0.9.10. does pokegen export the .dsv format? i dont think the .dsv format changed. lately i had problems with desmume 0.9.10 auto-importing .sav files and had to manually do it.

the recompiler cant cause issues with savefiles.

Offline

#3 2013-12-10 20:29:53

Pingouin7
Member
Registered: 2013-12-10
Posts: 8

Re: Save files being corrupted on read? (v0.9.10)

PokéGen supposedly is able to recognize and edit .dsv files properly. Worked fine when I was using DeSmuME 0.9.9, at least.
I have been told to try and use File --> Export backup memory after saving instead of directly editing the .dsv, I'm going to try that and get back to you.

Edit: Alright, I went and tried it, didn't work. I have to manually File --> Import Backup Memory for it to work.

I'm not sure if it's a problem on DeSmuME's end or a problem on PokéGen's end, because it only happens with PokéGen; I've tried editing something with Pokésav instead and the save file loaded properly (edited the .dsv directly in both cases.)

Last edited by Pingouin7 (2013-12-10 20:38:20)

Offline

#4 2013-12-10 23:11:50

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,710

Re: Save files being corrupted on read? (v0.9.10)

I just copied a .dsv from my old 0.9.8 directory into 0.9.10 and it loaded it just fine.
Given the available evidence, it sounds like pokegen is broken. hex edit a before and after(pokegen) file which didnt actually have any edits done to it and look for some bizarre differences.

Offline

#5 2013-12-11 00:18:27

Bond697
Member
Registered: 2013-12-11
Posts: 1

Re: Save files being corrupted on read? (v0.9.10)

Hello, I figured I should pop in since I'm the one maintaining PokeGen at the moment. 

The issue(I guess? Not 100% sure there) seems to be that Desmume is producing a 1mb save file for B2W2 instead of 512k.  Pokegen takes the 1mb save, edits/re-saves it to the proper size of 512k and then Desmume seems to refuse it because it's not 1mb anymore or something like that.

I know you guys improved the save-type detection in this version, but it seems to be getting it wrong for B2W2.

Last edited by Bond697 (2013-12-11 00:19:42)

Offline

#6 2013-12-11 00:33:36

Pingouin7
Member
Registered: 2013-12-10
Posts: 8

Re: Save files being corrupted on read? (v0.9.10)

I thought I should probably mention that it happens with HeartGold and Diamond as well.

Also, DeSmuME doesn't produce a 1MB save file on my end; my save file remains 512KB (well, 513KB with the extra stuff DeSmuME adds..)

Last edited by Pingouin7 (2013-12-11 00:43:38)

Offline

#7 2013-12-11 00:57:33

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,710

Re: Save files being corrupted on read? (v0.9.10)

ill let you guys get your notes in order. the `autodetection` may depend on whether the advanscene db is present..

Offline

#8 2013-12-11 02:48:00

Pingouin7
Member
Registered: 2013-12-10
Posts: 8

Re: Save files being corrupted on read? (v0.9.10)

Even when we have it set to Autodetect Save Type --> Internal instead of Database?

Offline

#9 2013-12-11 07:58:48

Geister 1121
Member
Registered: 2013-12-05
Posts: 4

Re: Save files being corrupted on read? (v0.9.10)

I am having saving issues too, not really important so i am not making a new thread , but some games seem to detect the save as corrupted ONLY when i switch from r4933 (0.9.11?)  back to 0.9.9 (Playing on r4933 saved and switched back to 0.9.9)

Saving is set to Autodetect. Happened with NSMB also FF IV and i do not remember if Pokemon Black too, other games seem to work fine.

However i compiled r4933 myself so it maybe just me.

Offline

#10 2013-12-11 08:16:02

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,710

Re: Save files being corrupted on read? (v0.9.10)

theres obviously something foul going on, so thanks for adding that

Offline

#11 2013-12-30 02:15:20

piau9000
Member
Registered: 2012-07-26
Posts: 14

Re: Save files being corrupted on read? (v0.9.10)

Just to add something:
It seems that the emulador is having trouble creating the save files. When you load the game for the first time it shows a message telling that it can't access the save file. Every game has a different message and it's happening with a lot of games.
If you reset or load the game again, it load fine and you can save and load normally and the message don't show up anymore (I'm not sure if everything is OK, though).

It happens in both, autodetect and database.

Version 0.9.10

The fastest example to test is the Dragon Quest games.

Offline

#12 2014-01-14 01:30:23

Carcaju
Member
Registered: 2014-01-14
Posts: 1

Re: Save files being corrupted on read? (v0.9.10)

Guys, I just downloaded the Desmume 0.9.10, and tryed Disgaea. You can't load or save the game, it says the file is corrupted.
So, after trying a few things, I went to "Path settings", and changed the path to the save files. Instead of ".\Battery", I put the whole path to the save file: in my case, C:\Desmume\Battery.

Please try that, and tell the rest of us if it worked.

Offline

#13 2014-01-14 02:47:08

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,710

Re: Save files being corrupted on read? (v0.9.10)

0.9.10 is a dud. its backup memory system is totally hosed. switch to 0.9.9

Offline

#14 2014-01-31 19:03:23

piau9000
Member
Registered: 2012-07-26
Posts: 14

Re: Save files being corrupted on read? (v0.9.10)

Carcaju wrote:

Guys, I just downloaded the Desmume 0.9.10, and tryed Disgaea. You can't load or save the game, it says the file is corrupted.
So, after trying a few things, I went to "Path settings", and changed the path to the save files. Instead of ".\Battery", I put the whole path to the save file: in my case, C:\Desmume\Battery.

Please try that, and tell the rest of us if it worked.

Did it fixed your problem?
Because it did nothing here.
Did you try what I said earlier (load a game first, quit, load game again)?
I don't have Disgaea to test so, maybe that's why your method did not work for me.

Offline

#15 2014-07-09 13:35:46

Zichqec
Member
Registered: 2014-07-09
Posts: 1

Re: Save files being corrupted on read? (v0.9.10)

I have this same problem, but I've found a way around it. The easiest way is just to play with 0.9.9, as files edited by Pokegen work just fine there. The other option I've found is to load files edited by Pokegen in Desmume 0.9.9 FIRST, then save in game, and then load them in 0.9.10. I've tested it a few times and it seems to work just fine. I know this reply may be a little late, but I figured maybe someone will come to this thread looking for answers like I did. Hopefully this will be useful to at least one person out there. smile

Offline

Board footer

Powered by FluxBB