You are not logged in.

Read the FAQ and Knowledge Base before posting.
WiFi not emulated and not supported!!
We won't make a 3DS/2DS emulator.

#1 2008-05-30 18:18:19

Registered: 2008-05-30
Posts: 4

Build problems in Linux

I'm running this on Ubuntu fully updated and with all of the required pre reqs, this is the error I get.

share/locale\"   -g -O2 -MT gdk_gl.o -MD -MP -MF .deps/gdk_gl.Tpo -c -o gdk_gl.o gdk_gl.c
gdk_gl.c: In function 'init_GL_capabilities':
gdk_gl.c:176: error: 'uint16_t' undeclared (first use in this function)
gdk_gl.c:176: error: (Each undeclared identifier is reported only once
gdk_gl.c:176: error: for each function it appears in.)
gdk_gl.c:176: error: syntax error before 'blank_texture'
gdk_gl.c:198: error: 'blank_texture' undeclared (first use in this function)
make[2]: *** [gdk_gl.o] Error 1
make[2]: Leaving directory `/home/macrod/desmume-0.8/src/gtk-glade'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/macrod/desmume-0.8/src'
make: *** [all-recursive] Error 1

I saw a similar problem here on the forums but that was fixed with dependency libgtkglext1-dev which I have.

Also to note I'm trying to compile this to run Inferno so I have included the patch from I've tried without the patch and get the same error.


Board footer

Powered by FluxBB