You are not logged in.

Read the FAQ and Knowledge Base before posting.
WiFi not emulated and not supported!!
We won't make a 3DS/2DS emulator.



#1 2007-05-19 12:26:45

musuruan
Member
Registered: 2007-05-19
Posts: 2

Compile error under FC6

Hi all,
I just tried to compile desmume 0.7.0 under Fedora Core 6 but I didn't succeded:

$ ./configure
[...]
$ make
[...]
../fat.h:116: warning: '__packed__' attribute ignored for field of type 'u8'
../fat.h:117: warning: '__packed__' attribute ignored for field of type 'u8'
callbacks_IO.c:84: error: conflicting types for 'init_GL'
gdk_gl.h:39: error: previous declaration of 'init_GL' was here
callbacks_IO.c:85: error: conflicting types for 'reshape'
gdk_gl.h:49: error: previous declaration of 'reshape' was here
make[2]: *** [desmume_glade-callbacks_IO.o] Error 1
make[2]: Leaving directory `/home/andrea/devel/desmume-0.7.0/src/gtk-glade'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/andrea/devel/desmume-0.7.0/src'
make: *** [all-recursive] Error 1

Any help is appreciated.

BTW, I had no problem in compiling version 0.6.0.

Andrea.

Offline

#2 2007-05-19 17:10:37

evilynux
Member
From: Montréal
Registered: 2007-03-17
Posts: 118
Website

Re: Compile error under FC6

musuruan wrote:

Hi all,
I just tried to compile desmume 0.7.0 under Fedora Core 6 but I didn't succeded:

$ ./configure
[...]
$ make
[...]
../fat.h:116: warning: '__packed__' attribute ignored for field of type 'u8'
../fat.h:117: warning: '__packed__' attribute ignored for field of type 'u8'
callbacks_IO.c:84: error: conflicting types for 'init_GL'
gdk_gl.h:39: error: previous declaration of 'init_GL' was here
callbacks_IO.c:85: error: conflicting types for 'reshape'
gdk_gl.h:49: error: previous declaration of 'reshape' was here
make[2]: *** [desmume_glade-callbacks_IO.o] Error 1
make[2]: Leaving directory `/home/andrea/devel/desmume-0.7.0/src/gtk-glade'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/andrea/devel/desmume-0.7.0/src'
make: *** [all-recursive] Error 1

Any help is appreciated.

BTW, I had no problem in compiling version 0.6.0.

IIRC, this problem occurs when trying to build desmume without 3D support.
The current version doesn't build without libgtkglext-dev and cie.

I recon that desmume should be buildable w/o 3D support, so it needs to be fixed.

Offline

Board footer

Powered by FluxBB