You are not logged in.

Read the FAQ and Knowledge Base before posting.
WiFi not emulated and not supported!!
We won't make a 3DS/2DS emulator.



#1 2007-05-14 16:51:59

Zion
Member
Registered: 2007-05-14
Posts: 15

Desmume v7.0 - anyone got it working on kubuntu/ubuntu

has anyone managed to get the new release of DesMuMe 0.70 working on kubuntu/ubuntu?

ive tried the packages and even compiled it myself with no joy sad

If anyone has got it working and would either share the binary or tell me how they did it I would appriciate it.

Thanks

Offline

#2 2007-05-14 17:30:38

evilynux
Member
From: Montréal
Registered: 2007-03-17
Posts: 118
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

Zion wrote:

has anyone managed to get the new release of DesMuMe 0.70 working on kubuntu/ubuntu?

Works on Debian unstable. But i'm biased, i made the packages.

Zion wrote:

ive tried the packages and even compiled it myself with no joy sad

You've built packages using my packaging files?

What actually fails? Please help me to help you.

Offline

#3 2007-05-14 17:31:37

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

i used the source code in the downloads section.

after compiling The binary just will not execute, just does nothing on trying to open it.

The previous release 6.0 worked fine on ubuntu and kubuntu.

same thing with package installs, binary just wont do anything.

Btw im not a linux noob, and know what im doing, thats why i find this odd

Last edited by Zion (2007-05-14 17:37:24)

Offline

#4 2007-05-14 17:48:48

evilynux
Member
From: Montréal
Registered: 2007-03-17
Posts: 118
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

Zion wrote:

i used the source code in the downloads section.

after compiling The binary just will not execute, just does nothing on trying to open it.

The previous release 6.0 worked fine on ubuntu and kubuntu.

same thing with package installs, binary just wont do anything.

Btw im not a linux noob, and know what im doing, thats why i find this odd

If i understand correctly, executing the binary just doesn't show anything and the process remains "active". Is that it?

0.6.0 did not have 3D support...
Is your 3D direct rendering environment setup correctly?
Do you use AIGLX?
Do you get warnings/errors on the console?

Do you get the same results from all three binaries? (desmume-cli, desmume and desmume-glade)

Offline

#5 2007-05-14 18:17:25

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

process never even starts as far as im aware.

and all my 3d stuff is fine, im happilly running mupen64 with no problems.

and yes i do im afriad sad

Offline

#6 2007-05-14 18:31:15

evilynux
Member
From: Montréal
Registered: 2007-03-17
Posts: 118
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

So nothing comes out on the command line when executing all 3 binaries and the process silently dies!?
It's very odd that you get the same results with desmume-cli as it doesn't use OpenGL at all and, AFAIK, should behave exactly as in 0.6.0 .

I can't help you with so little information...

Offline

#7 2007-05-14 18:37:08

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

libgl-mesa-glx is what i have installed that is the closest thing to alglx that i have installed.

http://prdownloads.sourceforge.net/desm … e?download

that is the one that does install but binaries do nothing

http://prdownloads.sourceforge.net/desm … e?download

i dont use glade so obviously that hangs on install.

ermm, i cant think of any other info i can give you...

Would knowing my gfx card or anything like that help?

thanks for your help so far

Last edited by Zion (2007-05-14 18:37:54)

Offline

#8 2007-05-14 18:46:38

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

wait a sec i might be onto something here...

brb

edit - right it works if i run this commmand

desmume --disable-3d

if i just run desmume i get this :

zion@Xion:/usr/games$ desmume
Nbr of joysticks: 0

X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  145
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  145
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
The program 'desmume' received an X Window System error.
This probably reflects a bug in the program.
The error was 'GLXBadContext'.
  (Details: serial 407 error_code 155 request_code 143 minor_code 5)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
zion@Xion:/usr/games$ desmume --disable-3d


i noticed another guy had the same problem - http://forums.desmume.org/viewtopic.php?id=138

but could only get it to work by disabling the 3d which sucks big time, the main reason i was updating from 0.60 was for the 3d emulation sad i hope someone knows how /or has overcome this problem without having to disable the 3d

Last edited by Zion (2007-05-14 19:04:39)

Offline

#9 2007-05-14 19:53:55

masscat
Member
From: UK
Registered: 2007-03-17
Posts: 73
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

The work around from the http://forums.desmume.org/viewtopic.php?id=138 does not disable 3D. That is you will be able to run Desmume and get 3D emulation.

The work around (see post #6 from the above thread) is to disable the AIGLX extension of X Window. This will bugger up any OpenGL based compositing window manager you are running (Compiz or Beryl).

So you have to choose between having Desmume 3D emulation or having flashy desktop effects (and some useful features).

Offline

#10 2007-05-14 19:56:50

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

im using neither compiz or beryl tongue

there not installed at least tongue maybe il get away with it then

edit - acutally i wont even be able to do that becuase i have no option to turn it off sad

that adds more wierdness to it not working for me. :S

Last edited by Zion (2007-05-14 20:04:48)

Offline

#11 2007-05-15 02:18:39

evilynux
Member
From: Montréal
Registered: 2007-03-17
Posts: 118
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

Can you report the output of "glxinfo | grep direct" at the command line?

Offline

#12 2007-05-15 15:27:37

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

sure one sec

Offline

#13 2007-05-15 15:31:16

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 6.5.2
OpenGL extensions:
    GL_ARB_fragment_program, GL_ARB_imaging, GL_ARB_multisample,
    GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_MESAX_texture_float, GL_ARB_texture_mirrored_repeat,
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
    GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_window_pos,
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_compiled_vertex_array, GL_EXT_convolution, GL_EXT_copy_texture,
    GL_EXT_draw_range_elements, GL_EXT_gpu_program_parameters,
    GL_EXT_histogram, GL_EXT_packed_pixels, GL_EXT_polygon_offset,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
    GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
    GL_APPLE_packed_pixels, GL_ATI_blend_equation_separate,
    GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
    GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat,
    GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
    GL_MESA_window_pos, GL_NV_blend_square, GL_NV_light_max_exponent,
    GL_NV_texture_rectangle, GL_NV_texgen_reflection, GL_NV_vertex_program,
    GL_OES_read_format, GL_SGI_color_matrix, GL_SGI_color_table,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x26 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x27 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x29 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2e 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2f 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x31 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x4b 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon

the output of grep direct is nothing, still hasnt shown anything

Offline

#14 2007-05-15 15:40:46

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

edit - this version works for me - http://ds.voidyourwarranty.us/downloads/?ac=file&id=112

but doesnt seem to run any 3d games sad

Offline

#15 2007-05-15 15:57:08

evilynux
Member
From: Montréal
Registered: 2007-03-17
Posts: 118
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

I see that your 3D environment is correctly set (direct rendering: Yes).
So that's not the issue...

I also see that your video card is an SGI... is that right?
We, developpers, only have NVIDIA and ATI cards and were only able to test those...

I'm quite out of ideas here...
You mention that the package at ds.voidyourwarranty.us works for you...
If you don't mind installing libglade2, my package should also work...

I don't know which 3D games you tried, but only a limited number of 3D games work at the moment... e.g. Super Mario 64 and NFSU2.

Offline

#16 2007-05-15 17:51:36

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

i have a ati radeon x300 tongue

just tried nfsu2 and it worked in game but the top screen was black (could only see speedometer)

testing mario64 now

il try your package, do you have a link?

super mario 64 also gets ingame , biottom screen is perfect. top screen green.

btw if your package is the one from the downloads section it wont install :S

Just hangs and doesnt install sad

unless you have a standalone binary of it?

Last edited by Zion (2007-05-15 18:03:44)

Offline

#17 2007-05-15 18:13:08

evilynux
Member
From: Montréal
Registered: 2007-03-17
Posts: 118
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

Zion wrote:

i have a ati radeon x300 tongue

And the vendor string says SGI?! Weird...

Zion wrote:

just tried nfsu2 and it worked in game but the top screen was black (could only see speedometer)

testing mario64 now

super mario 64 also gets ingame , biottom screen is perfect. top screen green.

That's weird... perhaps Masscat has thoughts on this...?
It should render almost perfectly (sky isn't rendered properly for me).
See:
http://organact.mine.nu/dokuwiki/lib/ex … io6414.png
to
http://organact.mine.nu/dokuwiki/lib/ex … io6420.png

Zion wrote:

btw if your package is the one from the downloads section it wont install :S

Just hangs and doesnt install sad

unless you have a standalone binary of it?

Yes, my packages are the ones from the download section.
Why doesn't it install? Dependency problem? if so, which dependencies?

Offline

#18 2007-05-15 18:28:05

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

just doesnt install :S progress bar sits at nothing and never moves sad

i installed that lib you refered to, its wierd sad

Offline

#19 2007-05-15 18:45:06

masscat
Member
From: UK
Registered: 2007-03-17
Posts: 73
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

Zion wrote:

OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX/SSE2 TCL
OpenGL version string: 1.3 Mesa 6.5.2

It looks like you are using the open source drivers for your ATI card. I do not know what 3D support is like with those drivers.

Try installing the ATI's closed source drivers. You should be able to install them through Synaptic or the restricted driver application (the packages begin with fglrx).

The blank screens in Mario and NFSU are what you get if 3D emulation is disabled or not working.

Offline

#20 2007-05-15 18:55:41

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

il try that now, thanks for the advice

Offline

#21 2007-05-16 15:49:44

evilynux
Member
From: Montréal
Registered: 2007-03-17
Posts: 118
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

Zion wrote:

just doesnt install :S progress bar sits at nothing and never moves sad

i installed that lib you refered to, its wierd sad

Hmmm... there should be some feedback...
A simple "dpkg -i the_package.deb" at the command line should do the trick...

Offline

#22 2007-05-16 17:30:55

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

desmume depends on libxml2 (>= 2.6.28); however:
  Version of libxml2 on system is 2.6.27.dfsg-1ubuntu3.

so that appears to be the problem.

ive checked my package manager but 2.6.27 is the latest one availible (on kubuntu anyway)

edit - downloaded and installed libxml2 2.6.28 manually, and then installed desmume (glade)

encountered same issues with glxbadcontent as i described above.

seems destined not to work (at least with 3d emulation anyway)

Last edited by Zion (2007-05-16 17:45:35)

Offline

#23 2007-05-16 21:00:35

evilynux
Member
From: Montréal
Registered: 2007-03-17
Posts: 118
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

Zion wrote:

encountered same issues with glxbadcontent as i described above.

seems destined not to work (at least with 3d emulation anyway)

I was expecting that. As mentionned by Masscat, you're not using the proprietary drivers from AMD/Ati.
Unless you install firegl and configure Xorg consequently, you won't get any hardware accelerated OpenGL.

Offline

#24 2007-05-16 23:50:09

Zion
Member
Registered: 2007-05-14
Posts: 15

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

so you reckon if i install the proper drivers from ati my problems will be solved?

il give it a go now

edit installing the propriety ati driver did nothing, same scenario.

any guides on configuring xorg....

despite getting nowhere i'm still not ready to give up yet wink

Last edited by Zion (2007-05-17 00:24:35)

Offline

#25 2007-05-17 09:06:22

masscat
Member
From: UK
Registered: 2007-03-17
Posts: 73
Website

Re: Desmume v7.0 - anyone got it working on kubuntu/ubuntu

Make sure that you are actually running X Window with the ATI drivers.
If you run glxinfo you should get something like (but with different card and version strings):

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9250/9200 Series DDR Generic
OpenGL version string: 1.3.1091 (X4.3.0-8.28.8)

In the Xorg configuration file (/etc/X11/xorg.conf) the ATI driver is fglrx where as the open source driver is radeon. Also make sure that there is the ATI kernel module loaded:

lsmod |grep fgl

The above should produce some output like:

fglrx                 394988  8
agpgart                29296  2 fglrx,via_agp

Without the kernel module accelerated 3D will not work.

Have a look at the Ubuntu support pages too.

Offline

Board footer

Powered by FluxBB