You are not logged in.

Read the FAQ and Knowledge Base before posting.
We won't make a 3DS/2DS emulator.



#1 2023-03-07 22:56:09

KM_64
Member
Registered: 2023-03-07
Posts: 1

Poor perfomance with i7 950

My computer specs meet the recommended and I'm unable to run almost any game without constant slowdown. I'm on Ubuntu 22.04, and am using lr-desmume, which is the libretro version that I can load through retropie. In the .sh file I tried setting desmume_JIT = 1, no change. On the standalone version perfomance is even worse. Usually, I get 50-60fps, with it hovering in the low to mid 50s, enough to slow it down and make it a bad experience. The output resolution has been set to the lowest possible, although I've gotten the same results regardless of the resolution, and since this emulator is so CPU heavy I'm sure it's a CPU issue. I know for a fact the CPU is not thermal throttling because I've repasted it and measured temps.

Any help is appreciated.

System specs:

i7 950 (4C/8T) @ 3.07 GHz
4GB DDR3 RAM @ 1066 MHz
RX 470 4GB

Offline

#2 2023-03-08 02:11:01

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 6,162

Re: Poor perfomance with i7 950

We don't support libretro desmume. On standalone desmume, follow the guide here
http://wiki.desmume.org/index.php?title … oo_slow.21

Define "any game". Some games should run several times faster than some others. If you get 50 on the slow ones and 50 on the fast ones then there's a problem with your system: GPU drivers interfering, strange choice of 50hz monitor and vsync enable, dust on your old cpu fan, malware processes, etc.

Offline

Board footer

Powered by FluxBB