You are not logged in.

Read the FAQ and Knowledge Base before posting.
WiFi not emulated and not supported!!
We won't make a 3DS/2DS emulator.



#1 2019-08-10 20:53:58

Runscream
Member
Registered: 2019-08-10
Posts: 2

[Solved] Lower performance on secondary monitor

Hi! My main display is a 1440p one. The emulator runs completely fine here. However, as soon as I slide the emulator window to my secondary screen, a 4k TV, performance goes down a lot, whether it's set to fullscreen or windowed mode. I guess the emulator tries to render at the screen's resolution, and thus performance goes down. How can I make it so that it renders at the same resolution despite the screen's resolution without having to go into display settings and changing the resolution every time? GPU scaling is set to 1 and I'm using DeSmuME_git#be2735b3_x64 nightly build.

Last edited by Runscream (2019-08-10 22:26:12)

Offline

#2 2019-08-10 21:51:35

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,045

Re: [Solved] Lower performance on secondary monitor

the emulator doesn't try that. it's a bug in your gpu drivers. changing config>display method to opengl is likely to make it happier though

Offline

#3 2019-08-10 22:25:28

Runscream
Member
Registered: 2019-08-10
Posts: 2

Re: [Solved] Lower performance on secondary monitor

zeromus wrote:

the emulator doesn't try that. it's a bug in your gpu drivers. changing config>display method to opengl is likely to make it happier though

Hey, thanks for the reply. That option was already enabled. I found out that for some reason my TV screen was set to 30hz. Since vsync and limit framerate were both enabled, the game was running at half speed. I set the refresh rate back to 60hz and now it's running smoothly.

Offline

#4 2019-08-10 22:38:27

zeromus
Radical Ninja
Registered: 2009-01-05
Posts: 5,045

Re: [Solved] Lower performance on secondary monitor

thanks for reporting back and marking it solved. it looks good in my annual performance review.

Offline

Board footer

Powered by FluxBB