You are not logged in.

Read the FAQ and Knowledge Base before posting.
We won't make a 3DS/2DS emulator.

#1 Re: Support » help ! CPU too hot high degree celcius » 2016-10-06 11:41:26

what a strange way to test CPU big_smile you can use some benchmarking programs maybe ? I recall there is option for CPU stress-test something like that in benchmark software
am using external fans
this ---> … _509.shtml
and this ---> … .19.KKu0nY
I believe my machine got enough care and maintenance smile

regarding my temperature test, latest Desmume is stable at 69 degree C
and I noticed that x432r is always run more cool than official (stable at 63 degree C)
so I hope official Desmume can surpass x432r in the future,
with better optimization maybe ? I am not technical person so I don't know much about this, don't take it seriously
like I said, I really thankful for what you did

#2 Re: Support » help ! CPU too hot high degree celcius » 2016-10-06 02:35:56

hi finto !
I did maintenance sometimes, I use good thermal paste too (I forgot the brand) the paste color is gray
my Lenovo Y410P is easy to dissamble, for fan cleanup purpose
in normal use my cpu is around 42 - 50 degree celcius, built-in windows 8
and you can see in my temperature test,
in my setup Desmume latest is using more cpu power, while Desmume x432r is more cool. I don't know why is that

#3 Re: Support » help ! CPU too hot high degree celcius » 2016-10-05 20:12:54

I did test just now, CPU Power Saving from x432r did work

here is the result


to see full view this is the link --->
I am just user
so I just can hope this feature is realized if possible

#4 Support » help ! CPU too hot high degree celcius » 2016-10-05 18:26:18

Replies: 9

first of all I am newbie please be gentle with me
my problem is CPU works too hard on latest Desmume

me use latest Desmume build r5561 x64
I use this setting :
- 2x HD scalling 3D using Softrasterizer
- Filter Nearest +1.5X
- CPU mode JIT tolerance 2
- Sound Sync method N, DIrect Sound Interface Linear buffer 5880
- Display method DirectDraw HW

don't tell me to downgrade my setting, I really like that setup (list setting in above)
hence - I don't intend to provoke Desmume developer in my next statement. Because I noticed if I mention X432R in here I will not get good response
I am very very Thankful for what you doing, I really meant it, please bear with me
I believe Desmume X432R have option like this : "CPU Power Saving"
and it really did wonder !
the difference is significant
by default x432r using the same setting as above (3D, sound, but without filter) my CPU is around 63 - 67 degree Celcius
then I turn on "CPU Power Saving" feature, now my CPU is around 55 - 60 degree Celcius never go beyond than that number (the difference is great right ? )
but if I use latest Desmume with the same setting, my laptop is around 69 - 76 Celcius !! and my laptop fan is running amok like crazy, because it is HOT
I not use X432R anymore !!
because the development Stop and can't support Magnification filter like latest Official Desmume
so going back to x432r is a big no no for me

so please,
can official Desmume have option for "CPU Power Saving" in the future ?

#5 Re: Support » some AR code not supported » 2016-10-05 08:07:47

just a wild guess, I don't even know what interpreter and JIT is
I compare CPU mode with frameskip because
if we use high frameskip the graphic will flip so much
I compare it with JIT high tolerance (3 or more up to 100), higher tolerance level makes AR code skipping *maybe*
I am not technical person sorry if my statement is not true tongue
CPU mode JIT is best for me, I will not let go of it

#6 Re: Support » some AR code not supported » 2016-10-05 06:47:11

maybe JIT works like frameskip
when I set JIT tolerance not more than 2
the AR code works as intended
if I increase the JIT tolerance to 3 or more, the code will not woking properly anymore
this applies to 0.9.11
still not tried older version, now I using latest Desmume
JIT is very good, I need it for better performance. and I believe tolerance 2 is good enough for my setup, rather than nothing at all (CPU interpreter)

#7 Re: Support » some AR code not supported » 2016-10-04 22:23:11

hi zero !
I ditch the x432r as per finto suggestion in this thread ---> … 932#p25932
now I use Desmume build r5561

ahh I see...
let's just hope everybody know that they can still activate JIT with full AR code support
when find this thread

I will go to that sticky post about speedup tips then
thanks !
EDIT : where is the speedup tips thread ? can you share the link please

#8 Re: General » about X432R performance and filter HELP !! » 2016-10-04 21:16:09

nail it !
The setting for higher resolution is called HD Prescalling
it's in Menu > Config > 3D Settings > HD Prescalling (increase as needed)


Thanks finto !

just now I tried your suggestion, Desmume build r5561
and try to setting this and that
but somehow I can't found where the Hi-Res setting is ?
please can you teach me how

#9 Re: Support » some AR code not supported » 2016-10-04 20:52:24

EDIT : SOLVED !! (again by trial and error) just now I have the optimal setting for that
to get a good portion of JIT feature with Support all AR code cheat feature
make sure option 'Use dynamic recompiler' is checked ON and use value 2 rather than 100 in its textbox form
BEWARE ! don't try to increase that value '2' into 3 or more !! Or the AR code will not working well again
now we can still get JIT feature for better FPS, and can support all Action Replay codes too !
hope this help

maybe Desmume can use this setting for future use

NOTE : option dynamic recompiler is in here
Menu > Config > Emulation Settings > Use dynamic recompiler


oohh Woops !
Correction !!
after some more testing, Desmume have GUI to change CPU mode
it's in Menu > Config > Emulation Settings > Use dynamic recompiler
checked means use CPU JIT
un-checked means use CPU interpreter

BUT ....
turn off this setting is NO good for me
because if I turn off 'dynamic recompiler'
Desmume is very Lag on my machine
is there any good solution for this ?

#10 Re: Support » some AR code not supported » 2016-10-04 20:29:12

Hi zero

but it seems I can't find GUI setting in Desmume to set CPU mode
then I go to Desmume folder
lucky me that I found the correct setting in 'DeSmuME_X432R_x64.ini'
by change this line (in Emulation group) ---> CPUmode=1
into this ---> CPUmode=0
I believe not all user know this manual change setting routine because CPU mode is not available in Emulation Menu group

I suggest you change default cpu mode to 0 from now on
so you will have less user that complain about code not working in the future wink

#11 Re: General » about X432R performance and filter HELP !! » 2016-10-04 20:03:09

thanks for replying !

ahh sorry...
I am newbie
so I apologize that I mention X432R in here

OK then
I will change the question then,
is Desmume gonna make Hi-Resolution available for the future ?
because the quality different is very noticeable
and make some people don't want to go back to native resolution (one of them is me)

#12 General » about X432R performance and filter HELP !! » 2016-10-04 19:29:12

Replies: 5

first I am sorry if Desmume x432R is not supported in here (I heard that made by some Japanese people ?? )
but in case there is someone resourceful and knowledgeable please reply

I really like 3D smoothing from x432R by increasing Desmume render resolution from 384p up to 784p
my rig can only handle 384p for stable gameplay 55 - 60 fps, Lenovo Y410P, vga nVdia with adequate VRAM
I can get stable flat 60 fps on Desmume native resolution, but I prefer Hi_res for 3D renderer
I turn on setting 'Use dynamic recompiler' @Menu > Config > Emulation Settings
and I turn on CPU Power Saving
also I use frameskip tolerance 3
my question is :

- how to make Desmume x432r stable at 60 fps for 384p ? I only got 55 - 60 fps ... and its bugging me because when fps drop below 60 there is lag and the sounds is a bit rigged

- is there a way to turn ON Filter for Hi-Res ? Because when I switch to Hi-Res, all the filter from Desmume in unavailable. My favorite filter is 2XSal, I can only use filter on native Desmume resolution. Which is in my humble opinion is NOT preferable ... the 3D quality significance is just too great compared with Desmume X432R Hi-Resolution

EDIT : Basically I want stable gameplay at 60 fps with latest Desmume X432R, and I want filter 2xSal to be enabled on Hi-Res 384p

post here if you know something. thx b4

#13 Support » some AR code not supported » 2016-10-04 19:00:10

Replies: 11

EDIT : SOLVED ! Oh my God ... just by switch my CPU into 'interpreter' mode rather than 'JIT' the code now is working fine !!
to switch to 'interpreter' mode, when you enter the emulator press 'Scroll-lock' button, then you'll see message like 'CPU interpreter' or 'CPU JIT'
make sure the last message that shown up is 'CPU interpreter' so all the Action Replay code will work as intended


Hello this is my first post please be gentle with me smile

I have something to report about Action Replay code and need solution
my desmume is version 0.9.11 64 bit also I tried the following version too but no good :
- 0.9.11 32 bit
- 0.9.12 32 bit
- 0.9.12 64 bit

I am playing Rune Factory 3
and I believe I use the correct AR code and correct localization version
I did test this code and it is working, the rune power get refill when I press A

# Refill RP press [A]
94000130 FFFE0000
023C0484 0FFFF000
D2000000 00000000

but ...
when I tried this code below ... nothing happen. it's NOT working

# Hold [A] Movement Speed x2
520A1A7C E1A00004
020A1A80 E1A01005
020A1A84 E1A02006
94000130 FFFE0000
020A1A80 E1A01085
020A1A84 E1A02086
D2000000 00000000

can someone give solution to me for this issue ?
out of curiosity I did test that 'Movement Speed x2' code with another emulator called NO$Zoomer
and it is WORKING ! I can run 2x speed when hold A button

this is just a wild guess
it seems to me that Desmume can't recognize code type 5 maybe ?
I need to customize my emulator setting, so I can support that code ?
because NO$Zoomer proved that code is working
hope get some reply
Thanks before !

Board footer

Powered by FluxBB